[cvsnt] Behaviour on laptop disconnected from network

Alpheratz alpheratz-news at transentia.com.au
Thu May 24 12:50:09 BST 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I have a WinXPSP2 laptop running CVSNT.

All is fine when I am connected to a network (I don't join any domain, 
either at work or at home).

If I disconnect from the network:

+ commits timeout
+ Sysinternals' "Process Explorer" shows me that cssservice has a 'zombie' 
cvs subprocess hanging around in the system
+ in my CVS TEMP directory I see a temp file whose name is related to the 
PID of the zombe cvs

I have a loopback adaptor installed and ping/tracert/netstat all 
look/function fine.

I have vmware adaptors active in the system and these function fine.

=> the TCP stack looks fine and active.

I hve tried removing the firewall from the loopback adaptor...no luck.

I am using myeclipseide 5.5ga (eclipse 3.2.2). I have tried using the cygwin 
cvs client and still have no luck. I HAVE set the various eclipse 
compatibility options in CVSNT. I am using pserver to connect. The CVS 
status indicators in the eclipse GUI look fine...they seem to refresh from 
the server OK.

I have tried both current (2382) and development (2685) CVSNT versions, both 
with no luck.

Can't find much through google...hence my post here...

Any suggestions gratefully accepted.

As you can see, I have tried a few permutations here and I have run out of 

My normal user (running eclipse) is NOT an administrator.


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook