[cvsnt] Behaviour on laptop disconnected from network

Arthur Barrett arthur.barrett at march-hare.com
Thu May 24 15:01:57 BST 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


If update and status work but commit doesn't it may be the lock server
that is causing the problem.  I am ALWAYS switching between different
networks and working on planes and I've never seen this.

Connect to the network, go to your sandbox and do: cvs status -ql and
check it all works. Then disconnect from the network and try again.  If
not OK then do cvs -ttt status -ql and check to see if there are useful
messages in the log.

If the status works ok, try a commit.  If that fails do the cvs -ttt
commit and check the log...

You can also run the cvslock.exe process in debug mode (interactively)
with cvslock -d (I think).



> -----Original Message-----
> From: cvsnt-bounces at cvsnt.org 
> [mailto:cvsnt-bounces at cvsnt.org] On Behalf Of Alpheratz
> Sent: Thursday, 24 May 2007 9:50 PM
> To: cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
> Subject: [cvsnt] Behaviour on laptop disconnected from network
> I have a WinXPSP2 laptop running CVSNT.
> All is fine when I am connected to a network (I don't join 
> any domain, 
> either at work or at home).
> If I disconnect from the network:
> + commits timeout
> + Sysinternals' "Process Explorer" shows me that cssservice 
> has a 'zombie' 
> cvs subprocess hanging around in the system
> + in my CVS TEMP directory I see a temp file whose name is 
> related to the 
> PID of the zombe cvs
> I have a loopback adaptor installed and ping/tracert/netstat all 
> look/function fine.
> I have vmware adaptors active in the system and these function fine.
> => the TCP stack looks fine and active.
> I hve tried removing the firewall from the loopback adaptor...no luck.
> I am using myeclipseide 5.5ga (eclipse 3.2.2). I have tried 
> using the cygwin 
> cvs client and still have no luck. I HAVE set the various eclipse 
> compatibility options in CVSNT. I am using pserver to 
> connect. The CVS 
> status indicators in the eclipse GUI look fine...they seem to 
> refresh from 
> the server OK.
> I have tried both current (2382) and development (2685) CVSNT 
> versions, both 
> with no luck.
> Can't find much through google...hence my post here...
> Any suggestions gratefully accepted.
> As you can see, I have tried a few permutations here and I 
> have run out of 
> ideas.
> My normal user (running eclipse) is NOT an administrator.
> Cheers! 
> _______________________________________________
> cvsnt mailing list
> cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
> http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook