[cvsnt] Permission mismatch

Tuan tusergroup at gmail.com
Tue May 13 04:54:07 BST 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Arthur Barrett wrote:
>> a Windows XP SP2 machine using SmartCVS Foundation 6.0.7 as the 
>> client.
> That is not a client - you need to find which cvs.exe it is actually
>  using and report that as the client, from a checked out sandbox just
>  type "cvs ver" and cvs should tell you the client version.

I don't understand how SmartCVS isn't my cvs client. I run a program 
called SmartCVS whenever I access the repositories.  I tried typing 'cvs 
ver' in the command line while I was in my working copy in Windows and 
Windows gave me an unrecognized program error.  Am I missing something here?

>> How should the permissions on the files in the repository be set 
>> for each file?
> That is a different unrelated question.  If you are really interested
>  the start a new thread please.  The permissions in your original 
> question are the permissions recorded "inside" the repository files.

I'm also confused about the permissions. Earlier you stated that the 
permissions were set using chmod in Unix.  I was also referring to the 
permissions that chmod is able to modify.  At the moment all my files in 
the repository are set to give read-only permission to everyone (chmod 
444). No other permissions are assigned besides read.  Isn't this the 
same permissions on the file we are both referring to? Because your last 
message indicated my permissions problem was related to the permissions 
on the file using chmod.  I am new to Linux and to CVS so your help and 
patience is appreciated.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook