[cvsnt] Connect PHPEclipse with CVSNT?

Steve McLeod sdmbizlists at broadrunit.com
Tue Nov 10 16:14:12 GMT 2009

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I think I am close to getting PHP Eclipse and CVSNT working together, but I
am missing something.


I am using XP Pro SP3.

I have WAMP server with Apache 2.2.11, MySQL 5.1.33, and PHP 5.2.9-2 running
without any troubles.

I have Zend PHPEclispe (Eclipse 3.5.0.I2009). This appears to be
working as I have a project that runs in the Zend debugger and Eclipse

I have March Hare CVSNT running. I see two services, cvslock and
cvsnt in the XP services list.

I've added two environment variables: CVS_RSH=C:\Program
Files\CVSNT\extnt.exe and CVSROOT=C:\CVSROOT.

The command line: cvs init -f -a MyProjects seems to have initialized the
directory indicated by CVSROOT.

I get this message: cvs init: Repository MyProjects <C:\CVSROOT> initialized

I have this directory structure after init:







In my Apache server I've created an alias http://localhost/CVSROOT to



At this web page I found some info.

In extnt.ini I have the following:










This command:

cvs -d :ext:. at CVSROOT:/CVSROOT/MyProjects version

also cvs -d :ext:. at CVSROOT:/CVSROOT/CVSROOT version

also cvs -d :ext:. at CVSROOT:/CVSROOT version

Produces this message:

[extnt] Unknown response 'error 0 /CVSROOT: no such repository

What am I doing wrong?


I do not understand the syntax or parameters in these phrases:

:ext:. at CVSROOT:/CVSROOT/MyProjects


:pserver:anonymous at dev.eclipse.org:/cvsroot/eclipse

This one is an example from Eclipse.


I assume that anonymous is a userid and that . (period) substitutes for the
absence of a userid?

I assume that wherever I see a URL in an example that I should substitute
localhost for my local Apache server?

According to the directions I should be able to paste the following into the
Eclipse host name and voila!

:ext:. at CVSROOT:/CVSROOT/MyProjects

But I get this:

Error validating location: "Unknown response received from cvs server: "

Looks familiar. What am I doing wrong?


I have Shu-Wai Chow's book, "PHP Eclipse: A User Guide", and tried his
pserver instructions with no better results.

He indicates the necessity of establishing a userid and password in CVSNT
that is the same as the XP userid and password. The command he uses on page
163 did not work and my attempts at using pserver with Eclipse have worked
no better than my attempts using ext.

I get this message:

Error validating location: "Could not connect to
:pserver:. at localhost:/CVSROOT: I/O exception occurred: Connection refused:
/CVSROOT: no such repository"

What am I doing wrong?


Steve McLeod

Broad Run, Virginia


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook