[cvsnt-dev] Help using a manual build of cvs

Eric B. ebenze at hotmail.com
Sat Jun 27 14:31:29 BST 2009

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

> Making changes to 2.5.04 makes a it of a mess of the development process - 

> there are not significant changes between 2.5.04 and 2.5.05, so better 
> use 2.5.05.  The dev branch for the community has always been and 
> will be CVSNT_2_0_x.

Thanks.  I wasn't sure based on the 
branch name. :)

>> installed.  After some more investigation, it 
seems as
>> though MarchHare
>> signs all the files prior to 
making them publicly
>> available.
> Yes - this is to 
identify that these builds were built according to our 
> quality process 
and are the 'official' cvsnt.org ones so that it's clear 
> if someone 
maliciously modifies the code and tries to pass it off as 

After a little frustration, I had figured that to be as 

>> Otherwise, how do I proceed in
>> modifying it so 
that I can use it?  How do I test out my changes?
> You need to 
get your own signing keys from verisign or whoever.

But if were to use my 
own signing keys, I would need to rebuild/resign 
everything; I wouldn't be 
able to just modify something in cvs.exe and 
redeploy it  

>> Is there a way to disable signature 
> I think it is #ifdef'd in CVSAPI - just add the 
correct pre-processor 
> define and it wont be compiled in.

I tried 
doing that and it didn't work; it would just hang.  Well, not 
true.  I didn't change the preproc definition, I just commented out 
the part 
of the if statement that says abort and exit, recompiled and 
replaced my 
entire installation directory with stuff from winrel, thinking 
that would 
work.  However, like I said, my cvs client would just hang.  I 
even tried 
using -ttt to see something of a trace, but I didn't get 

E:\Dev\Projects\eric-test\etc\terracotta>cvs -ttt commit 
15:24:55:   -> Tracelevel set to 3.  PID is 
15:24:55:   -> Session ID is 64c4a4520875f90
15:24:55:   -> 
Session time is Fri Jun 26 19:24:55 2009
15:24:55:   -> Loading protocol 
pserver as pserver.dll
15:24:55:   -> CLibraryAccess::Load loading 

15:24:55:   -> main 
loop with CVSROOT=:pserver:eric at cvs.mydomain.com:/dame5
cvs [commit aborted]: 
received interrupt signal

Do I need to change my client as well to be 
unsigned at that point?



Windows Live helps you keep up with all your friends, in one place.

More information about the cvsnt-dev mailing list