[cvsnt] Re: corruption of binary files on checkout

Corey Wirun corey at wirun.homelinux.net
Sat Oct 22 17:58:44 BST 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I changed my server back to GNU CVS, and it worked (i.e. no corruption of
LF/CR), with my identical client configuration.

I put back on the server and took WinCVS out of the picture (CVS
command line directly) and it again failed.  So WinCVS wasn't the culprit.

I took your configuration and put on the client AND server and
it worked fine - no corruption.

So there was apparently something incompatible between the older CVSNT
client (2.0.51d) and the new server (

Anyway, I'm back in business.

Thanks for your time.

----- Original Message ----- 
From: "Corey Wirun" <corey at wirun.homelinux.net>
To: <cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook>
Sent: Friday, 21 October, 2005 16:49
Subject: Re: [cvsnt] Re: corruption of binary files on checkout

> Additional information - I just tried importing a completely different
> module and some .lib, .bmp, and .ico's were corrupted.
> I did an octal (od) dump on the two files (a .bmp file).
> good file:
> 0324020 ... 323 136 *015* 110 110 110 110 110 057 136 136 146
> bad file:
> 0324020 ... 323 136 *012* 110 110 110 110 110 057 136 136 146
> This appears for every 012 character in the (good) source file.  Doesn't
> sound like 'regular' corruption to me, does it?
> Wincvs insists the checked out file is -kb (binary), so some binary/ascii
> setting is getting clobbered somewhere.
> Corey.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook