[cvsnt] cvsnt server: invalid RCS expansion flags

xavier xsure at icarvision.com
Thu Jun 12 13:08:10 BST 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Hi all,
 I have a problem after a good moving of the repository from CVS to CVSNT.
 The error is when I try to download the repository with TortoiseCVS, it
crashes with a cvsnt server: invalid RCS expansion flags error.
 The situation is:
-	Main Server: Debian with CVS and original repository.
-	Auxiliar Server: Debian with CVSNT and a copy of the repository.
-	Subfolders have been deleted by TortoiseCVS. So, fisically we still
can see the subfolders in the servers, but it woldn't have to download.
Downloading to Main Server, everything OK. Downloading to Auxiliar Server,

 I've tried some combinations in the file /etc/inetd.conf and allways the
same result.
 Now I have the line cvspserver stream tcp nowait root /usr/bin/cvsnt cvsnt
-f -allow-root=/home/cvs pserver in auxiliar server and cvspserver stream
tcp nowait root /usr/sbin/tcpd /usr/sbin/cvs-pserver in the main one.
 And I don't know where to look forward.
 I'll thank all the help you can give me.

  On my PC: 	TortoiseCVS version 1.10.6
		CVS Client: Concurrent Versions System (CVSNT) 2.5.03
(Scorpio) Build 2382
		SSH Client: TortoisePlink: Release 0.60
 Aux Server:	Concurrent Versions System (CVSNT) 2.5.03 (Scorpio) Build
2383 (client/server)
Main Server:	Concurrent Versions System (CVS) 1.12.13 (client/server)
Both Servers:	Debian (Lenny repository)

Xavier Sureda

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook